JavaFX 2.0 Beta TIP 1.

Pues con la novedad que ya salió JavaFX 2.0 (beta), y si como siempre solo para Windows Microsoft ("#$%).

http://javafx.com/
http://www.oracle.com/technetwork/java/javafx/overview/index.html

Como nos damos una ligera idea de cómo se come ahora esto? Pues sigue estos simples pasos.

1. Descarga el jdk: http://download.oracle.com/otn/beta/javafx/javafx_sdk-2_0-beta-windows-i...
2. Lo descomprimes y navegas hasta javafx_sdk-2_0-beta-windows-i586\javafx-sdk2.0-beta
3. Ejecutas el javafx-2_0-beta-windows-i586.exe
4. Con un IDE (yo use NetBeans 6.9.1) abres un proyecto ya existente navegando hasta la carpeta javafx_sdk-2_0-beta-windows-i586\javafx-sdk2.0-beta\apps\src
5. Elijes uno y no queda más que probar.

Y conste que lo deje en la categoría de JSE a propósito.
Suerte a todos y pásenla chévere :D

JavaFX Tip 1

AdjuntoTamaño
JavaFxTip1.JPG16.68 KB

Comentarios

Opciones de visualización de comentarios

Seleccione la forma que prefiera para mostrar los comentarios y haga clic en «Guardar las opciones» para activar los cambios.

Errores

Lo estoy probando y me han salido algunos errores, uso el entorno eclipse y con 64bits pero espero que si me funcione, tendré que hacer otras pruebas.

saludos.
Laoth.

Error: failed to msvcr100.dll java.lang.UnsatisfiedLinkError: C:\javafx\javafx_sdk-2_0-beta-windows-x64\javafx-sdk2.0-beta\rt\bin\msvcr100.dll: Can't find dependent libraries
*** Fallback to Prism SW pipeline
Exception in thread "main" java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: C:\javafx\javafx_sdk-2_0-beta-windows-x64\javafx-sdk2.0-beta\rt\bin\mat.dll: Can'
t find dependent libraries
        at com.sun.javafx.tk.quantum.QuantumToolkit.startup(QuantumToolkit.java:245)
        at com.sun.javafx.application.PlatformImpl.startup(PlatformImpl.java:30)

Quizá te falto instalar el runtime, esto es lo que yo hice:

Entrar a http://oracle.com/javafx que redirecciona a:

Downloads:

Luego descomprimir el archivo y dar click en el instalador:

Abrir

Tomar alguno de la carpeta apps:

Y sorprenderse:


Por cierto yo tengo Chrome y actualizó el plugin correctamente, solo manda una advertencia de que tengo una versión vieja ( ja )

Por cierto no lo pude evitar:

Imagen de Sr. Negativo

ja ja estuvo bueno

@OscarRyz

Estuvo bueno, ja ja ja

Ryz FX

Se ve genial esa transcripcion a Ryz... será algo como RyzFX o simplemente Ryz?

por cierto cuando se maneje algo como o de este codigo, creo qee va a chocar bastante http://javafx.com/samples/PhotoFlockr/index.html

Ese es el punto, JavaFX2.0

Ese es el punto, JavaFX2.0 significa la eliminación de JavaFX script ( el código al que te refieres ) y dejar todo como biblioteca ( bajo el paquete javafx )

Como es una biblioteca Java más puede ser usado por cualquier lenguaje que corra sobre la JVM, puede ser JRuby, Jython, Scala, Clojure o como en este caso Ryz , ahh Groovy por supuesto :")

Imagen de rodrigo salado anaya

@Laoth

Que onda si pudiste correr las demostraciones?

Imagen de baskpro

problemas con javafx

tengo un problema no ejecuta mi jar echo en javafx solo corren los archivos jnlp pero el jar no y cuando copio los archivos en otra maquina no pasa nada ya e instalado en otra maquina javafx jdk y jre y nada