style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-5164839828746352"
data-ad-slot="7563230308">

Sugerencia para un novato!

Que tal!,

Estoy practicando y aprendiendo JAVA con el libro de Fco. Javier Ceballos, referente a sus ejercicios tengo una duda, hay ocaciones en las que escribe por elemplo:

public void areaCirculo()
{
return pi * radio* radio;
}

mas que pregunta es un consejo lo que les solicito, en todas las cuestiones (limpieza, memoria, legibilidad), me recomiendan usar asi los return, o lo mejor es:
public void areaCirculo()
{
double area;
area = pi * radio * radio;
return radio;
}

De antemano gracias.

Opciones de visualización de comentarios

Seleccione la forma que prefiera para mostrar los comentarios y haga clic en «Guardar las opciones» para activar los cambios.

Errores

Tienes un error grave en ambos códigos. El error es que cuando utilizas void no puedes utilizar return. Void significa que método no va a regresar nada.
Por otra parte es obvio que el segundo código es más limpio que el primero (aunque tiene otro error, ya que regresa el radio en vez de el área). Como costumbre está bien,pero si el código es pequeño, así como el tuyo, el primer método es inofensivo y no hay mucho problema.

Imagen de francisco.santiagoj

Que pena o_O

Que tal Luis,

Creo que ayer ya estaba cansado, después de trabajar llegue a estudiar, tienes toda la razón, mi errores son más que evidentes, gracias por el consejo, desde ahorita que estoy estudiando quiero hacerme buenos hábitos de programación y por eso mi consulta.

controlar sentencia codigo

lo mejor para estos casos es desde eclipse ., si esas trabajando con el por supuesto es hacer control+shift+f y si quieres más
aún estrito utilizar plugins por ejemplo PDM o CHECKSTYLE hay varios para estos mundos informaticos. buena suerte

Imagen de Armel

Mejor así, creo...

public double areaCirculo(double xRadio){
    double nArea=0;
    double nRadio=xRadio;
    if(nRadio >0){
       double nArea = pi * (nRadio*nRadio);
    }
   return nArea;
}

Para algo tan sencillo, es

Para algo tan sencillo, es mejor la primera versión:

public double areaCirculo( double radio ) {
    return pi * radio * radio;
}

Es simple, es directo, es claro.

style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-5164839828746352"
data-ad-slot="7563230308">