style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-5164839828746352"
data-ad-slot="7563230308">

Mejor versión para desarrollar en java

Saludos,
Hay un asunto que me tiene un poco confundido, sobre las versiones de java
Yo en lo personal me he mantenido con la 1.6 desarrollo más en web spring Mvc, jsp, angular, jsf, ect. Pero muchos me dicen que debo actualizar por el tema de json y aplicaciones REST, pero con la versión 1.6 puedo generar json con Jackson
Cuando ves las empresas las versión de java no es la 1.8, incluso usan versiones 1.4
Entonces quiero saber que versión de java utilizas actualmente para tener una idea si estoy muy atrasado o que?
es necesario subir de versión ?

Saludos,

Opciones de visualización de comentarios

Seleccione la forma que prefiera para mostrar los comentarios y haga clic en «Guardar las opciones» para activar los cambios.

Tienes que actualizarte pero

Tienes que actualizarte pero no por json o por REST, no tienen nada que ver con la versión de Java que uses.

Es mejor estar actualizado porque las mejoras de desempeño y las actualizaciones de seguridad se aplican en las versiones nuevas. También hay parches de seguridad para versiones pasadas pero solo por cierto tiempo, por ejemplo Oracle dejó de actualizar Java 1.6 en el 2013

Mantenerse siempre actualizado

En nuestra profesión hay que estar actualizado tanto como sea posible, y si somos programadores Java, pues hay que estar actualizado a la ultima versión del lenguaje y la plataforma. Tal vez en las empresas aún no ocupen las últimas versiones de Java, eso generalmente sucede cuando hay que darle mantenimiento a las aplicaciones. Pero cuando se trata de nuevos proyectos, y estamos actualizados, podemos sugerir usar las ultimas versiones estables de las tecnologías. Creo que si no nos actualizamos siempre vamos a estar trabajando con las misma versiones aunque ya haya mejores.

Imagen de ezamudio

Obsolescencia

Si bien es cierto que hay empresas que siguen en Java 1.4, no es por gusto. Muchos tienen miedo o no han tenido tiempo de actualizar a las siguientes versiones. Entre más tiempo pase, más difícil va a ser que se actualicen. A veces es porque alguna biblioteca externa ya no funciona en versiones más nuevas y no han tenido tiempo de buscar o desarrollar un reemplazo, pero muchas veces es simplemente miedo, o falta de recursos (tiempo, gente, equipos) para probar que todo funcione en versiones más recientes.

Eso no significa que debas quedarte en versiones tan viejas. Creo que al menos deberías estar usando Java 7, pero la verdad, todos deberíamos estar usando Java 8, porque Java 7 ya fue EOL'd hace un año. Si te toca un cliente que usa una versión arcaica de Java pues ya tendrás que adaptarte, pero deberías siempre estar desarrollando con la versión más reciente, incluso si no utilizas todas sus bondades.

Ahora, que utilices Java 8 no significa que tengas que recompilar todo tu código y todas las bibliotecas que utilices; simplemente que utilices esa versión para compilar y para ejecutar tus aplicaciones. El equipo que desarrolla la JVM y el JDK siempre son bastante cuidadosos de mantener compatibilidad con versiones anteriores, de modo que es muy muy raro que una biblioteca hecha en una versión anterior (digamos Java 6) no funcione con la JVM de Java 8. Y si eso llega a suceder, la solución casi siempre consiste simplemente en encontrar una versión más reciente de dicha biblioteca.

style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-5164839828746352"
data-ad-slot="7563230308">