style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-5164839828746352"
data-ad-slot="7563230308">

Duda con libreria Primefaces

Hola

Tengo una duda, porque al querer importar las siguientes clases y a pesar de que ya incluí en mi proyecto el .JAR de PrimeFaces me marca que no las encuentra.

Algun consejo para solucionar esto....

import org.primefaces.event.map.GeocodeEvent;
import org.primefaces.event.map.ReverseGeocodeEvent;
import org.primefaces.model.map.GeocodeResult;

Gracias por el consejo.

Saludos.

Opciones de visualización de comentarios

Seleccione la forma que prefiera para mostrar los comentarios y haga clic en «Guardar las opciones» para activar los cambios.

Re: GeocodeEvent

 

Me parece que esas clases no existen en la distribución “regular” del JAR de PrimeFaces (Community), pero podrías descargar el código y generarlo.

~~~

Imagen de CesarAlducin

@jpaul te refieres al .JAR de

@jpaul te refieres al .JAR de primefaces porque ya lo descargue y no encuentro esas clases.

O si están pero estoy buscando mal

Saludos

De nuevo... (ja, ja)

 

No existen esas clases en el JAR (asumiendo que descargaste la versión Community (*) ).

Sin embargo, tú puedes descargar el código y generar el JAR correspondiente.


Notas

* Sospecho que así será hasta que Çağatay Çivici quiera incluirlas.

~~~

Imagen de CesarAlducin

Ahora si, entendido Gracias

Ahora si, entendido

Gracias

Imagen de CesarAlducin

Otra Duda, Resulta ser que la

Otra Duda,

Resulta ser que la funcionalidad

<script type="text/javascript">
    function geocode() {
        PF('geoMap').geocode(document.getElementById('address').value);
    }
 
    function reverseGeocode() {
        var lat = document.getElementById('lat').value,
            lng = document.getElementById('lng').value;
 
        PF('revGeoMap').reverseGeocode(lat, lng);
    }
</script>

Solo esta disponible a partir de la Versión de PrimeFaces 5.1.2, pero esa tiene costo.

Yo uso la 5.0, entonces existe alguna forma de poder invocar esa funcion de JavaScritp desde mi Versión de PrimeFaces.

Gracias de nuevo

No

 

Seguramente te refieres a este ejemplo: GMap - Geocode (since v5.1.2). Supongo que aún no has descargado el código y generado el JAR, ¿verdad?

Imagen de CesarAlducin

Sí, eso ya lo hice pero en el

Sí, eso ya lo hice pero en el Tag

  <p:Ajax event="geocode">

Me dice que ese evento (geocode) no es soportado.

Me imagino que en la versión que tengo de PrimeFaces aun no es soportado ese evento.

Porque las clases que anteriormente necesitaba las agregue manualmente a mi proyecto.

Gracias.

style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-5164839828746352"
data-ad-slot="7563230308">