style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-5164839828746352"
data-ad-slot="7563230308">

com.sun.faces.config.ConfigurationException: CONFIGURATION FAILED! Unknown Schema version: 2.1

No puedo correr un programa, me tira este error...

cannot Deploy StudentHibernate
Deployment Error for module: StudentHibernate: Exception while loading the app : java.lang.Exception: java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: com.sun.faces.config.ConfigurationException: CONFIGURATION FAILED! Unknown Schema version: 2.1
!ENTRY oracle.eclipse.tools.glassfish 4 0 2012-12-02 19:13:58.811
!MESSAGE cannot Deploy StudentHibernate
!STACK 1
org.eclipse.core.runtime.CoreException: Deployment Error for module: StudentHibernate: Exception while loading the app : java.lang.Exception: java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: com.sun.faces.config.ConfigurationException: CONFIGURATION FAILED! Unknown Schema version: 2.1

        at com.sun.enterprise.jst.server.sunappsrv.SunAppServerBehaviour.publishDeployedDirectory(SunAppServerBehaviour.java:859)
        at com.sun.enterprise.jst.server.sunappsrv.SunAppServerBehaviour.publishModuleForGlassFishV3(SunAppServerBehaviour.java:629)
        at com.sun.enterprise.jst.server.sunappsrv.SunAppServerBehaviour.publishModule(SunAppServerBehaviour.java:277)
        at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publishModule(ServerBehaviourDelegate.java:1046)
        at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publishModules(ServerBehaviourDelegate.java:1138)
        at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(ServerBehaviourDelegate.java:955)
        at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(ServerBehaviourDelegate.java:774)
        at org.eclipse.wst.server.core.internal.Server.publishImpl(Server.java:3108)
        at org.eclipse.wst.server.core.internal.Server$PublishJob.run(Server.java:345)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
!SUBENTRY 1 oracle.eclipse.tools.glassfish 4 0 2012-12-02 19:13:58.811
!MESSAGE Deployment Error for module: StudentHibernate: Exception while loading the app : java.lang.Exception: java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: com.sun.faces.config.ConfigurationException: CONFIGURATION FAILED! Unknown Schema version: 2.1

Ya no se que hacer para que funcione adecuadamente.

Opciones de visualización de comentarios

Seleccione la forma que prefiera para mostrar los comentarios y haga clic en «Guardar las opciones» para activar los cambios.
Imagen de Sr. Negativo

Tienes un error en la configuración de tu esquema

Lo muestra claramente:

com.sun.faces.config.ConfigurationException: CONFIGURATION FAILED! Unknown Schema version: 2.1

Tal vez modificaste algún archivo de configuración (me imagino un *.xml) o algo. Tal vez te hace falta una librería o algo así, son suposiciones por que solo posteas el error.

Busca en el faces.config.xml.

Imagen de teebia

faces.config.xml

No modifique nada, instale todo de 0 y me sigue tirando el mismo error.
Este es el faces.config.xml...

<?xml version="1.0" encoding="UTF-8"?>

<faces-config xmlns="http://java.sun.com/xml/ns/javaee"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="http://java.sun.com/xml/ns/javaee <a href="http://java.sun.com/xml/ns/javaee/web-facesconfig_2_1.xsd"
" title="http://java.sun.com/xml/ns/javaee/web-facesconfig_2_1.xsd"
">http://java.sun.com/xml/ns/javaee/web-facesconfig_2_1.xsd"
</a>    version="2.1">

</faces-config>

Imagen de Sr. Negativo

¿tu creaste el faces.config?

O ¿estás usando un IDE como Eclipse o Netbeans?

<?xml version="1.0" encoding="UTF-8"?>
http://java.sun.com/xml/ns/javaee/web-facesconfig_2_1.xsd"
    version="2.1">

Me llama la atención la parte donde esta:  version="2.1 no sé si este bien

Imagen de ingscjoshua

mmm

Si estas usando faces 2 ? para que quieres el facesConfig? ya no lo necesitas!!!! es la magia de Faces 2 todo va contra anotaciones y lo que dice le Sr. negativo es cierto me hace ruido eso puedes subir tu web.xml? y tus archivos de configuración igual tienes un error por ahi. Revisa que tus xml tengan los tags cerrados corectamente aveces eso revienta la carga del archivo

Imagen de teebia

version 2.0

Lo configure con la version 2.0 y me funciono correctamente.
Configures a Dynamic Web application to use JSF v2.0

Pero ahora tengo otro problema...
Ahora creo otro tema y quizas me puedas ayudar.

style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-5164839828746352"
data-ad-slot="7563230308">