style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-5164839828746352"
data-ad-slot="7563230308">

¿Como actualizar el IDE Eclipse a la versión de Java 7?

Que tal comunidad un saludo a todos, veran tengo la necesidad de cambiar la versión de Java en Eclipse, no quiero bajarla sino poner la 7. Ya baje el jdk 7 y ya le busque por todos lados a las configuraciones y cuando actualizo el jdk me sigue marcando error en el editor. Quiza alguno de ud que tambien trabaja con el Eclipse ya pudo hacerlo o tuvo la misma necesidad y sabe cual es la respuesta.

Este es el problema que tengo:

Uploaded with ImageShack.us

Bueno espero alguna respuesta. Saludos.

Opciones de visualización de comentarios

Seleccione la forma que prefiera para mostrar los comentarios y haga clic en «Guardar las opciones» para activar los cambios.

Edita el compiler y build path

En eclipse, en las propiedades del proyecto debes seleccionar Java Build Path y de agregar una Libreria de tipo JRE System Library. Le das en Alternate JRE y agregas tu java 7.

Para el compilador, tendras que poner tu codigo en Java 7, eso es en el menu Java Compiler (dentro de las propiedades de tu proyecto)

Imagen de ezamudio

compatibilidad

La bronca puede estar en varios lugares. Veo que ya instalaste JDK 7 y lo agregaste a las JRE's disponibles en Eclipse. Pero tal vez el nivel de compatibilidad en el proyecto (o en el workspace) sigue siendo 6 y no 7. Eso creo que se ve en las opciones del compilador de Java.

Imagen de AlexSnake

Correcto.

Exactamente tal y como ambos lo mencionan la bronca es en el Java Compiler del IDE, solo que no me aparece la opcion para cambiar a la ver 1.7 en el "Compiler compliance level", creo que tengo que actualizar el eclipse de acuerdo a lo que mencionan aquí

Saludos.

Imagen de paranoid_android

Algunas tecnologias son restrictivas

Algunas tecnologías son restrictivas a una versión de java como SWT, en web también puedes ver en la configuración de facets la versión de JEE. Si no aparece Java 7 puedes intentar si la nueva versión de eclipse ya la contempla. Saludos.

Imagen de ingscjoshua

Eclipse

mm no puedo ver el tu imagen gracias a las restricciones de el internet del trabajo pero si a lo que te refieres es aque tu proyecto compile en jdk podrias intentar lo siguiente .
en el menu window -->preferences --->java--> compiler--> y buscar que compile con 1 .7
save

Ojo esto solo hara que todo el workspace compile en 1.7 asi si creas un proyecto nuevo este por default compilara en 1.7

si quieres q se a solo el proyecto se hace asi
click derecho sobre tu proyecto properties y de ahi buscas la opcion de proyecfacets --->java --->1.7

y de ahi ya le das applay y de ahi ya te vas a java compiler ahi mismo y ya deberia salirte java 1.7

Nota esto lo hice en eclipse Helios nose si en otras versiones anteriores funcione jejej

Imagen de AlexSnake

Eclipse Galileo

De hecho la versión que estoy ocupando el Galileo 3.5, tengo que cambiar a alguna version ya sea la que tu mencionas o al E. Indigo SR1 como lo mencionan en stackoverflow en una pregunta similar.

Saudos

Imagen de puzzlemaniaco

pus veras

pues veras yo uso eclipse indigo y java 7 sin ningún problema no tengo que hacer ninguna configuración ni nada y bueno el error que te marca que no es por que el case solo acepta enteros ???

Imagen de neko069

El punto es que: Java 7

style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-5164839828746352"
data-ad-slot="7563230308">